Re: Radeon RX580 and trouble with Ffmpeg

Top Page
Message as email
+ (text/plain)
+ (text/html)
+ (text/plain)
Delete this message
Reply to this message
Author: Jim via PLUG-discuss
To: z via PLUG-discuss
CC: Jim
Subject: Re: Radeon RX580 and trouble with Ffmpeg
Thanks.  I've read that tonight.  Earlier just for the fun of it I
installed the Radeon drivers on winsows10.  I installed handbrake and
had it transcode the same video I experimented with earlier.  When I
chose the codec,  I found H.264 (AMD_VCE).  There was also an H.265
AMD_VCE option but I didn't try it.  Handbrake in Windows was
transcoding the video at around 100 to 110 fps and only using 1% of the
CPU.  I may not use hardware acceleration for encoding often, but I'd
like to have it available.  It doesn't matter to me if I use the open
source drivers or the proprietary ones.  I can't help but wonder why it
won't work in Linux.

On 4/5/24 15:29, z via PLUG-discuss wrote:
> I also don't think I made it clear that mesa is probably better than
> the proprietary AMD drivers on linux. The same is untrue on NVIDIA.
> Apr 5, 2024 15:11:16 z via PLUG-discuss <>:
>     Do you truly need proprietary drivers? That card is one of the
>     best supported by open source software. So I would just install
>     mesa, which should be easily installed from your distro's package
>     manager, if it's not installed already.

>     Assuming you do need proprietary, maybe try a reboot if you
>     haven't already? It's giving a missing binary error and sometimes
>     I get those after a kernel update and not rebooting.

>     Zack

>     Apr 5, 2024 14:43:44 Jim via PLUG-discuss
>     <>:

>         Today the Radeon RX580 graphics card I bought arrived. To get
>         the drivers for the card, I went here

>  where I downloaded
>         amdgpu-install_6.0.60002-1_all.deb

>         Next I started following the instructions at
> then I
>         started running into problems.

>         amdgpu-install --vulkan=amdvlk,pro gave me 2 errors:

>         E: Unable to locate package vulkan-amdgpu-pro and the same for
>         vulkan-amdgpu-pro:i386

>         I kept going and entered amdgpu-install -y --usecase=workstation

>         That returned the errors Unable to locate package amdgpu-pro
>         and amdgpu-pro-lib32

>         With the error messages I figured I'd have problems, but I
>         tried to find out if I could use the hardware acceleration so
>         I entered|:|

>         |ffmpeg -i input.mp4 -c:v h264_amf -c:a copy output.mp4

>         That gave me several errors.  The first one was [h264_amf @
>         0x562e1f855380] DLL failed to open|

>         |So I tried sudo updatedb and locate which
>         returned nothing.  That told me the file wasn't there.|

>         |I tried to transcode a file with Handbrake but it didn't show
>         h264_amf among the available codec options.|

>         |I tried searching for how to install but all
>         I got was references to steps I already tried.
>         |

>         |Did I make a mistake somwhere or does AMD need to fix something?|

>         |Thank for your help.|

>         |Jim
>         |

> ---------------------------------------------------
> PLUG-discuss mailing list:
> To subscribe, unsubscribe, or to change your mail settings:
PLUG-discuss mailing list:
To subscribe, unsubscribe, or to change your mail settings: