I use PIA here. I have it manually setup on both the old linux laptop and this mac. The app they provide was not screen reader accessible, so I went with the manual configuration instead.


On May 25, 2018, at 6:56 AM, pademc1 wrote:

I tried Goose VPN(my first ever VPN) and couldn't get it to work on m my Mint 18 system. They're support eam wasn't much help.
I bought a subscription to PIA VPN on a recommendation I read here. It installed perfectly. It worked fine till I tried to use it. I use Firefox browser and Duck Duck go for a search engine. Anyway I hit the icon for Facebook waited about two minutes and received a connection problem. Same thing with 4 other websites. I used Las Vegas, Sweden and New York as connection points.
Anyone else having an issue with PIA?
Thanks, Dennis 

"You cannot help men permanently by doing for them what they could and should do for themselves."
Abraham Lincoln
PLUG-discuss mailing list - PLUG-discuss@lists.phxlinux.org
To subscribe, unsubscribe, or to change your mail settings: